laptop_studio_1537_295

In questi giorni ho avuto occasione di installare Ubuntu su un paio di bei computer Dell Studio 15, per la precisione modello Studio 1537.

Nel primo dei due (quello di Massimino) ho operato uno spianamento totale del sistema operativo preinstallato (Vista) per reinstallare in parallelo Ubuntu e WindowsXP, mentre nel secondo (quello di Fabio) ho mantenuto Vista.
L’operazione più difficile è stata la conversione ad XP, nella fattispecie per il reperimento dei driver necessari; chi fosse interessato ad intraprendere la stessa impresa, può trovare indizi utili qui e qui.

L’installazione di Ubuntu non ha presentato particolari problemi, solo un piccolo inceppamento nel caso di Vista, in cui dopo aver ridimensionato la partizione di vista, non si riusciva più ad aprire alcun menu o casella a discesa per definire i mountpoint. Ricominciando l’installazione da capo, senza quindi dover di nuovo ridimensionare Vista, il problema non si è presentato; c’è da dire però che stavo usando la versione beta di Intrepid.

Le periferiche sono riconosciute automaticamente in grande abbondanza, servono i driver proprietari solo per la scheda wireless (che ancora non ho capito come mai, funziona anche prima di abilitarli…) e, volendo, per la scheda video ATi.

Per far funzionare la webcam integrata, in un caso è stato sufficiente installare il pacchetto “linux-backports-modules-intrepid” dai repository di Ubuntu, mentre nell’altro la stessa operazione non ha sortito effetto alcuno, ed è stato necessario installare il pacchetto “uvcvideo-kernel-source” dal PPA di Pablo Marcondes. In entrambi i casi, con al prossima release molto probabilmente tutto funzionerà out-of-the-box®.

Per utilizzare i microfoni incorporati, è sufficiente abilitare le due voci “digital input source” nel mixer ed impostarle a “Digital Mic 1”.

Un discorsetto a proposito dell’audio: passando il parametro “snd-hda-intel model=dell-m6” in /etc/modprobe.d/alsa-base si ottiene che entrambi i jack delle cuffie funzionino a dovere, escludendo le casse, però si perde l’uso del microfono.
Passando “model=auto” o qualsiasi altro parametro che mi sia venuto in mente, il massimo che sono riuscito a fare è che uno dei due jack riproduca l’audio in contemporanea alle casse, mentre l’altro muti sia le casse che le cuffie… il codec in uso è uno STAC92xx, non si trova moto su internet al riguardo, se qualcuno ha qualche idea la posti nei commenti, che fa sempre bene.

Il touchpad a volte presenta un comportamento un po’ anomalo, soprattutto sembrerebbe con l’alimentazione a batteria: può succedere che diventi irresponsivo o, al contrario, che si metta a fare strani scatti e “click fantasma”.
Il problema si presenta (raramente, per fortuna!) anche sotto windows, quindi probabilmente sarà dovuto a qualche bacherello nel bios o simili.
Per ora ho trovato, per Ubuntu, un parametro da passare al kernel (quindi da inserire in menu.lst) che sembra soluzionare, ma data la rarità con cui si resenta il fenomeno e lo scarso tempo che ho passato usando questi laptop, non ci metterei la mano sul fuoco…
Il parametro è questo: “i8042.nomux=1”
Non ho la più pallida idea di cosa possa significare, non me lo chiedete 😛

Voto complessivo del laptop: molto buono, mi piace!

Advertisements